VietTUG.org - old forum - threads' archive

thread_id = 4517, contains 4517, 4518, 4519, 4520, 4521, 5047, 5051, 5053, 5054, 5055, 5057
id = 4517, parent = 0, thread = 4517, catid = 14, locked = 0, moved = 0,
userid = hchon, ip = 58.187.109.238, time = 2008/04/27 (1209243799) ,
subject = Cấu hình cho kile?, hits = 2036, karma = 0+0-,
Hôm nay /me vừa cài lại máy tính vì thấy bản Ubuntu-8.04 hấp dẫn quá. Khi cài xong mới gặp vấn đề là không thể cấu hình cho kile 2.0 nhận Tiếng Việt được. Cụ thể như sau:

Sau khi cài U xong, /me cài texlive 2007 vào myhome từ CD. Sau đó /me cài kile 2.0 từ mạng do đó nó được cài trong tài khoản root. Kết quả là mọi thứ tốt đẹp, nhưng không cấu hình cho kile nhận texlive ở myhome được mà nó mặc định nhận texlive được cài kèm khi cài kile 2.0.

Ai có cách nào cấu hình kile được xin chỉ giáo với. Thanks a lot!
 
id = 4518, parent = 4517, thread = 4517, catid = 14, locked = 0, moved = 0,
userid = viettug, ip = 125.234.185.226, time = 2008/04/27 (1209248103) ,
subject = Re:Cấu hình cho kile?, hits = 0, karma = 0+0-,
mình dùng arch, xvnkb gõ tiếng việt trên Kile rất bình thường.

vừa xem ở vnoss có topic này không gõ được tiếng việt với ubuntu.804+xvnkb.

Theo topic đó, bác thử
* disable scim (nếu có)
* chỉnh local thích hợp cho xvnkb

Tất nhiên, nếu bác dùng keyboard khác thì ...
 
id = 4519, parent = 4518, thread = 4517, catid = 14, locked = 0, moved = 0,
userid = hchon, ip = 118.71.132.199, time = 2008/04/27 (1209249988) ,
subject = Re:Cấu hình cho kile?, hits = 0, karma = 1+0-,
viettug hiển sai ý minh rồi.

Không phải minh không gõ TV được trong kile mà là một lỗi khác. Cụ thể như sau:

Theo mình hiểu thì khi cài kile thì nó mặc định cài thêm một số gói của texlive phục vụ cho việc nhấc lệnh (Không biết đúng không).

Do đó khi cài theo qui trình của mình (texlive --> kile) thì có đến 2 texlive, 1 trong myhome, 1 trong /usr/..

Khi biên dịch texfile kile măc nhiên dùng texlive trong /usr/... mà không dùng texlive mình đã cài trong myhome. Có cách nào để kile nhận texlive trong myhome không?
 
id = 4520, parent = 4519, thread = 4517, catid = 14, locked = 0, moved = 0,
userid = viettug, ip = 125.234.185.226, time = 2008/04/27 (1209253971) ,
subject = Re:Cấu hình cho kile?, hits = 0, karma = 0+0-,
sorry đã trông gà hóa cuốc.

cách đơn giản là gỡ bỏ bản texlive đã cài đi? được không?

kile không cần biết texlive hay là không. chỉ biết có excutable `tex` file thôi. thử từ terminal:
type -a tex

xem ra kết quả gì? xem tập tin `tex` để thi hành trong $HOME có hiện ra không? nếu không, hoặc nếu có mà ở sau cái <system-texlive-path>/bin/tex thì có nghĩa là `tex` của hệ thống đã được kile nhận trước.

kết quả trên máy của /me:
type -a tex
tex is /opt/texlive/bin/tex

Nếu không muốn gỡ bỏ texlive hệ thống, thì thử
export PATH=<YOUR_TEXLIVE_PATH/bin>:$PATH

(bỏ trong $HOME/.bashrc). logout, login và chạy lại xem???
 
id = 4521, parent = 4520, thread = 4517, catid = 14, locked = 0, moved = 0,
userid = hchon, ip = 118.71.132.199, time = 2008/04/27 (1209283363) ,
subject = Re:Cấu hình cho kile?, hits = 0, karma = 0+0-,
Cảm ơn viettug. Mình đã đưa thêm đường dẫn vào như viettug hướng dẫn thì mọi thứ ok. Thanks a lot!
 
id = 5047, parent = 4521, thread = 4517, catid = 14, locked = 0, moved = 0,
userid = qthac, ip = 195.83.155.55, time = 2008/09/17 (1221599502) ,
subject = Re:Cấu hình cho kile?, hits = 0, karma = 0+0-,
Mình sử dụng Kile 2.0 và gõ tiếng Việt bằng x-unikey, có hai vấn đề gặp phải:
1. Một số ký tự không hiển thị được .
2. Khi biên dịch thì các ký tự tiếng Việt bị lỗi, ra các ký tự không có nghĩa.
Xin các bạn hướng dẫn cách giải quyết. Cảm ơn nhiều.
 
id = 5051, parent = 5047, thread = 4517, catid = 14, locked = 0, moved = 0,
userid = garcon, ip = 117.2.11.84, time = 2008/09/17 (1221655474) ,
subject = Re:Cấu hình cho kile?, hits = 0, karma = 0+0-,
Mình cũng gặp tình trạng này ở ubuntu 8.04 + Kile 2.0 +xvnkb. Trước đây dùng Ubuntu 7.04+Kil1.9+Xvnkb thì tốt. Theo ngu ý của mình thì là do bộ gõ X-unikey (đã có truyền thống là chưa tương thích với ubuntu) và bộ gõ Xvnkb chưa tương thích với ubuntu 8.04. Có ai có ý kiến khác không?
 
id = 5053, parent = 5047, thread = 4517, catid = 14, locked = 0, moved = 0,
userid = viettug, ip = 125.234.191.190, time = 2008/09/17 (1221665340) ,
subject = Re:Cấu hình cho kile?, hits = 0, karma = 0+0-,
qthac:
Mình sử dụng Kile 2.0 và gõ tiếng Việt bằng x-unikey, có hai vấn đề gặp phải:
1. Một số ký tự không hiển thị được .
2. Khi biên dịch thì các ký tự tiếng Việt bị lỗi, ra các ký tự không có nghĩa.
Xin các bạn hướng dẫn cách giải quyết. Cảm ơn nhiều.
Mình không kinh nghiệm về chuyện này. Sau đây là gợi ý để xác định lại lỗi: bạn thử mở trong KILE một tập tin (encoding utf-8) được soạn thảo không có lỗi trong editor khác (nghĩa là mọi chữ đều đọc được), xem có được không, khi KILE hiển thị có gì trục trặc không?
 
id = 5055, parent = 5053, thread = 4517, catid = 14, locked = 0, moved = 0,
userid = qthac, ip = 85.192.209.184, time = 2008/09/18 (1221688314) ,
subject = Re:Cấu hình cho kile?, hits = 0, karma = 0+0-,
Mình đã thử cách của bạn, và kết quả là: Hiển thị file đó ở Kile thì ổn, không bị lỗi dấu lỗi font gì, nhưng khi biên dịch ra thì vẫn ra ký tự loằng ngoằng, ví dụ chữ à thì ra thành Ã... gì đó (dấu bảng Anh).
Cảm ơn các bạn chỉ giáo.
 
id = 5057, parent = 5055, thread = 4517, catid = 14, locked = 0, moved = 0,
userid = viettug, ip = 125.234.191.190, time = 2008/09/18 (1221699574) ,
subject = Re:Cấu hình cho kile?, hits = 0, karma = 0+0-,
Bạn gặp 2 vấn đề:

1. chưa gõ được tiếng Việt với KILE (bạn tự khắc phục nhờ các diễn đàn Linux. Ở http://forum.vnoss.org/ có chủ đề này.)

2. bạn chưa cài đặt vntex đúng cách, hoặc... Bạn cho mình xem tập tin *.log thu được để biết lỗi cụ thể!
 
id = 5054, parent = 5047, thread = 4517, catid = 14, locked = 0, moved = 0,
userid = dtq, ip = 146.140.220.142, time = 2008/09/18 (1221687981) ,
subject = Re:Cấu hình cho kile?, hits = 0, karma = 0+0-,
qthac:
Mình sử dụng Kile 2.0 và gõ tiếng Việt bằng x-unikey, có hai vấn đề gặp phải:
1. Một số ký tự không hiển thị được .
2. Khi biên dịch thì các ký tự tiếng Việt bị lỗi, ra các ký tự không có nghĩa.
Xin các bạn hướng dẫn cách giải quyết. Cảm ơn nhiều.
Xác xuất là có người dùng kubuntu + kile + x-unikey + tex chắc gần bằng zero
Chắc ăn hơn có lẽ là bạn nên bắt đầu hỏi trên forum của x-unikey trước. Giải quyết xong vấn đề đó rồi mới xét đến tex.
Tip: Bạn thử check lại cái locale xem
locale
Nó phải output đại loại thế này
LANG=en_US.UTF-8